ReadyNAS Package PHP5-IMAP: Dependency Hell

I just uploaded the PHP5-IMAP package to ReadyNASFreeware.org. This was harder than expected because of some really ugly dependency problems introduced with RAIDiator 4.1.5.

{openx:6}

That’s because the latest version of Netgear’s

php5-imap

was compiled against a version of

libc-client-2001

that included SSL support whereas the one shipping with RAIDiator 4.1.5 doesn’t. Thus I had to grab the newer

libc-client-2002

(which in fact is also a 2001 version, albeit modified) and do some creative symlinking.
Initial tests showed no problems so I felt safe to release it as a beta version. As the version number 0.1.6 shows, it took me more than one attempt to get it right ;)
For the moment, this again is NV/NV+/Duo/1100/600/X6 only. If you’re interested in a version for the PRO, let me know.